SEARCH FINESCALE.COM

Enter keywords or a search phrase below:

Hobby Boss Land Rover WMIK w/ MILAN ATGM 1/35 scale

1085 views
20 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    October, 2016
Hobby Boss Land Rover WMIK w/ MILAN ATGM 1/35 scale
Posted by Mrchntmarine on Tuesday, March 13, 2018 10:33 PM

out of curiousity, anyone done one of these lately from HobbyBoss?  I’m working on one now and am having trouble with fit - exhaust to engine, air filter, radiator on frame crooked, etc. Had to really bend part of the exhaust and file down part of air filter. Having to use a lot of glue....

 

Still new to this - is this “normal” for hobby boss??  I haven’t seen a lot of these kits done, unless I missed them on the search. Did see 1 or 2 old ones but no comments on fit. Just curious - anyone?  Tks!!

  • Member since
    September, 2006
  • From: Dripping Springs, TX, USA
Posted by RBaer on Tuesday, March 13, 2018 10:46 PM

No idea on this kit, and I have only built one HobbyBoss kit, a Merkava IV, but it had a couple of major fit issues.

Apprentice rivet counter.

  • Member since
    October, 2016
Posted by Mrchntmarine on Monday, April 16, 2018 3:27 PM

so here are some pics - have to do a little paint touch up, etc.  then im gonna try pledge clear coat & some washing....

 

  • Member since
    December, 2002
  • From: Fort Knox
Posted by Rob Gronovius on Tuesday, April 17, 2018 9:04 AM

No photos are visible.

  • Member since
    October, 2016
Posted by Mrchntmarine on Tuesday, April 17, 2018 10:01 AM

okay, really weird....  when i log in to the site, using safari, i see the pictures.  im now on firefox and i dont see them.  im posting them again now on firefox.  tks

 

 

  • Member since
    December, 2002
  • From: Valrico, FL
Posted by HeavyArty on Tuesday, April 17, 2018 10:34 AM

Looking good.  I don't see the prior pictures, but the above set shows up fine.  I am using Google Chrome.

Gino P. Quintiliani - Field Artillery - The KING of BATTLE!!!

Check out my Gallery: http://smg.photobuck...v231/HeavyArty/?

"People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf." -- George Orwell

  • Member since
    November, 2009
  • From: SW Virginia
Posted by Gamera on Tuesday, April 17, 2018 1:03 PM

Oh gee, I'm getting nothing on my Android phone with Pale Moon or the office PC with WinX and Chrome. 

"I dream in fire but work in clay." -Arthur Machen

 

  • Member since
    October, 2004
  • From: Northern Virginia
Posted by ygmodeler4 on Tuesday, April 17, 2018 10:13 PM
Blanks for me; when I click on them it requires me to sign into a google account though, which I do not have.

-Josiah

  • Member since
    October, 2016
Posted by Mrchntmarine on Wednesday, April 18, 2018 9:15 AM

ive never had som much trouble posting pictures!  I got the email notification of my post and the pictures were there - both times....  Im off to the user forum to see if you cant use google..

  • Member since
    December, 2002
  • From: Valrico, FL
Posted by HeavyArty on Wednesday, April 18, 2018 10:34 AM

Weird.  Now all the pics are gone for me too.  It sounds like an issue using the Google-hosting.  

Gino P. Quintiliani - Field Artillery - The KING of BATTLE!!!

Check out my Gallery: http://smg.photobuck...v231/HeavyArty/?

"People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf." -- George Orwell

  • Member since
    September, 2012
Posted by GMorrison on Wednesday, April 18, 2018 11:36 AM

I tried Google after blowing out of PB. It seemed that if it could work, I'd have instant access to my image cache on my own server.

I never could get it to work, same problem.

Now I'm paying $ 24 a year for Fotki and it works really well.

I'd love to see the model. I think Bish was a Milan gunner.

 

  • Member since
    October, 2016
Posted by Mrchntmarine on Wednesday, April 18, 2018 12:04 PM

ill have to try later.  i posted the same in the test forum, got the notification email with pictures showing but now they are gone....

  • Member since
    October, 2016
Posted by Mrchntmarine on Thursday, April 19, 2018 4:12 PM

hopefully you can see them now, above???

  • Member since
    December, 2002
  • From: Bury St Edmunds, Suffolk, England
Posted by Bish on Friday, April 20, 2018 1:53 AM

GMorrison

I tried Google after blowing out of PB. It seemed that if it could work, I'd have instant access to my image cache on my own server.

I never could get it to work, same problem.

Now I'm paying $ 24 a year for Fotki and it works really well.

I'd love to see the model. I think Bish was a Milan gunner.

 

 

Ye, i was a MILAN operator for 4 years. Great bit of kit to fire, PITA to carry.

I don't see any pics at the moment, but then i am at work. Depending on what host is being used, i can see some at work, with Firefox but not at home, with windows, and in other cases its the bother way round.

It seems to be getting more and more difficult to post pics and iu am sureits not the forum as that has not changed recently.

''I am a Norfolk man, and i glory in being so''

 

On the bench: Rudel Stage 3

                     Academy 1/72nd Apache AH.1

  • Member since
    October, 2016
Posted by Mrchntmarine on Saturday, April 21, 2018 12:55 PM

okay, i think i have it now

 

 

https://photos.app.goo.gl/bV4by3JBsA1X4jJ92

sorry, i still cant figure out how to get them to show in the post

  • Member since
    December, 2002
  • From: Bury St Edmunds, Suffolk, England
Posted by Bish on Saturday, April 21, 2018 1:11 PM

You need to hit the reply button and useing the insert/edit image function copy and paste your links.

It looks nice, will look good with a wash on.

One question, it looks as though the MILAN tube is open at the front, am i seeing that right.

''I am a Norfolk man, and i glory in being so''

 

On the bench: Rudel Stage 3

                     Academy 1/72nd Apache AH.1

  • Member since
    October, 2016
Posted by Mrchntmarine on Saturday, April 21, 2018 1:23 PM

before gloss pledge

and after......

 

  • Member since
    November, 2009
  • From: SW Virginia
Posted by Gamera on Monday, April 23, 2018 11:56 AM

Don't know what you did, but I can see all your photos perfectly now. Yes

Despite your problems a nice clean build there. Great work! 

"I dream in fire but work in clay." -Arthur Machen

 

  • Member since
    October, 2016
Posted by Mrchntmarine on Saturday, April 28, 2018 10:07 PM

okay, I have no idea what I'm doing, but here are some with Flory Wash used.....  Still working it, bt it seems like the blind leading the blind.  I need a good manual!!  I saw some pics with just panel lines accented and that looked good too.  Any suggestions?  Tks

 

  • Member since
    November, 2009
  • From: SW Virginia
Posted by Gamera on Monday, April 30, 2018 7:51 AM

Looks pretty good to me. 

The nice thing about the Flory washes is that they're easy enough to remove if you don't like the results. You can even touch-up small areas with a moist cotton swab without messing up the surrounding detail. 

"I dream in fire but work in clay." -Arthur Machen

 

  • Member since
    October, 2016
Posted by Mrchntmarine on Sunday, May 20, 2018 8:41 PM

Okay, did a little more and finished up.  Suggestions / comments welcome.  Enjoyed this and it was fun messing with the washes.  Did a littlle pinwashing for the 1st time.  Flat cpated with acryl.

JOIN OUR COMMUNITY!

Our community is FREE to join. To participate you must either login or register for an account.

SEARCH FORUMS

FREE NEWSLETTER
By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our Privacy Policy.