SEARCH FINESCALE.COM

Enter keywords or a search phrase below:

Not receiving any information from forums - I am not alone

1415 views
0 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    February 2010
  • From: Berkeley CA/St. Paul MN
Not receiving any information from forums - I am not alone
Posted by EBergerud on Sunday, July 29, 2018 8:52 PM

I have ceased receiving any posts from this GB nor the Commonwealth GB that I am also subscribed to. I've checked "Email Notifications" and it says I am not subscribed to any forums. However, under "Forum Topics" everything is listed. Toward the end of the Forum list there is a technical assistance forum. As I understand it, other modelers are having the same problem. I urge everyone that's having trouble to make a post there. As everything was going fine for me on this forum until about a week ago (and yes I subscribed) and then halted, it's got to be glitch on their end. For me the Group Build Forum is basically crippled. It's nuts to make people manually check all messages themselves. As I understand it, Facebook hosts a multitude of modeling sites. Although the idea is a bad one, if Finescale can't get their act together, I'll have to start using them.

Any advice greatly appreciated.

Eric Bergerud

 

A model boat is much cheaper than a real one and won't sink with you in it.

JOIN OUR COMMUNITY!

Our community is FREE to join. To participate you must either login or register for an account.

SEARCH FORUMS
FREE NEWSLETTER
By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our Privacy Policy.