SEARCH FINESCALE.COM

Enter keywords or a search phrase below:

AIr compressor issues

462 views
9 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    March, 2015
AIr compressor issues
Posted by Peaches on Saturday, September 09, 2017 2:29 AM

Hey everyone maybe one of y'al can help me figure this one out.  I don't know if it's the compressor or the Airbrush.  It's a HF 3 gallon hotdog compressor.  WHen ever I try to paint something there is air coming out of the ab, however no paint comes out, it's perfectly thinned as well as the nozzle being cleaned out.  

Now here is the interesting part when ever I try to clean the nozzle by creating backpressure there are no bubbles in the cup.  THough everyonce in a while it does paint, and it does an amazing job.

There is a leak at the QD, but it isn't that bad.  Though when I used a spray gun to paint it worked perfectly.  Any thoughts or comments would be helpful.  

WIP:
Academy F-15 (1/72)

On Deck 

MH-60G 1:48 (Minicraft)

C-17 1/144

KC-135R 1/144

Academy F-18(1/72)

Ting Ting Ting, WTF is that....

  • Member since
    May, 2017
  • From: ohio I want to leave
Posted by armor 2.0 on Saturday, September 09, 2017 7:31 AM
Check ab hose for blockage
  • Member since
    March, 2007
  • From: Northeast WA State
Posted by armornut on Saturday, September 09, 2017 9:37 AM

Is your airbrush gravity or siphon feed?  Single or double action? If it is a siphon feed you may not have your regulator set high enough to pull the paint up out of the jar. If it's a double action thete is a chance that even clean your needle is sticking and your trigger is just sliding back without actually pulling the needle to release paint.

we're modelers it's what we do

  • Member since
    March, 2015
Posted by Peaches on Sunday, September 10, 2017 7:04 AM

It's a gravity fed Badger DA.  When I had it off the hose, I looked at the needle and it is being pulled back.  

WIP:
Academy F-15 (1/72)

On Deck 

MH-60G 1:48 (Minicraft)

C-17 1/144

KC-135R 1/144

Academy F-18(1/72)

Ting Ting Ting, WTF is that....

  • Member since
    October, 2008
  • From: Fullerton, Calif.
Posted by Don Wheeler on Sunday, September 10, 2017 11:39 AM

If you can't blow air back into the cup by backflushing, something must be blocking that path. Either that or the air pressure is extremely low.

Don

https://sites.google.com/site/donsairbrushtips/home

A collection of airbrush tips and reviews

Now also an Amazon E-book and paperback of tips.

  • Member since
    March, 2007
  • From: Northeast WA State
Posted by armornut on Sunday, September 10, 2017 11:57 AM

I agree with Don, you may have rolled an "O" ring out of its seat causing the blockage as well was the intermittent functioning. You may not realize it has happened  if you clean after each use by taking it completely down then reassembling and not using it for awhile. Gravity fed should work with alot lower pressure than siphon but it is worth checking. My next question is since you cannot blow air back, do you feel it coming out of the nozzle?

we're modelers it's what we do

  • Member since
    March, 2015
Posted by Peaches on Sunday, September 10, 2017 5:32 PM

I do feel air, but it's extremely low, even when I crank the pressure up to about 30.  I am beginning to think that air leak is more the problem than anything.  

WIP:
Academy F-15 (1/72)

On Deck 

MH-60G 1:48 (Minicraft)

C-17 1/144

KC-135R 1/144

Academy F-18(1/72)

Ting Ting Ting, WTF is that....

  • Member since
    March, 2007
  • From: Northeast WA State
Posted by armornut on Sunday, September 10, 2017 6:15 PM

Yeup, fix the leak then let us know if your problem still exsists. If your getting alittle air out of the nozzle with the pressure up then it isn't a blockage. Air has to be going somewhere.

we're modelers it's what we do

  • Member since
    March, 2015
Posted by Peaches on Monday, September 11, 2017 11:13 PM

Sooo, apparently the issue was OE.  I wasn't screwing the backing (?) for lack of better words.  Once I tightened the whole thing worked like a charm.  Makes me wonder if that's what was wrong with the other airbrushes I had...Huh?

WIP:
Academy F-15 (1/72)

On Deck 

MH-60G 1:48 (Minicraft)

C-17 1/144

KC-135R 1/144

Academy F-18(1/72)

Ting Ting Ting, WTF is that....

  • Member since
    March, 2007
  • From: Northeast WA State
Posted by armornut on Tuesday, September 12, 2017 1:09 PM

No worries Peaches, happens to all of us. Glad ya got it fgured out.

we're modelers it's what we do

JOIN OUR COMMUNITY!

Our community is FREE to join. To participate you must either login or register for an account.

SEARCH FORUMS

SUBSCRIBER-ONLY CONTENT
FREE NEWSLETTER